Results 1 to 4 of 4

Thread: Use vnodebypass to avoid jailbreak detection (best solution as of May 2022)

  1. #1
    Owner Dan Druff's Avatar
    Reputation
    8694
    Join Date
    Mar 2012
    Posts
    50,005
    Blog Entries
    2
    Load Metric
    29232415

    Use vnodebypass to avoid jailbreak detection (best solution as of May 2022)

    Certain apps are trying very hard to stop you from running them on a jailbroken phone.

    First, try getting Liberty Lite, and seeing if that works. If it doesn't, you may need vnodebypass.

    KernBypass used to be the solution here, but unforunately some newer apps can tell if you have KernBypass installed, so they will fail to open.

    In case you want to try KernBypass, instructions (and the relevant file links, updated 10/1/21) here: https://pokerfraudalert.com/forum/sh...-one-will-work!

    However, if KernBypass has stopped working for you, you will want to REMOVE IT, and get vnodebypass.

    As of May 2022, you should NOT need KernBypass anymore, as it is obsolete!

    Here's how:

    *** MAKE SURE YOU DO EXACTLY AS LISTED BELOW -- IF YOU SCREW UP, DON'T BLAME ME ***

    *** INSTRUCTIONS UPDATED MAY 2022 ***

    1) Prerequisites: Newterm (terminal program). Install from Cydia first. Make sure to disable other jailbreak bypass apps for any apps which are still seeing the jailbreak.

    2) If you don't have KernBypass installed, skip to step #8

    3) Reboot phone. Re-jailbreak. Do NOT do the Newterm commands for KernBypass that you otherwise do after re-jailbreaking.

    4) Go to Newterm and type: rm /var/mobile/Library/Preferences/jp.akusio.ke*

    4b) If you never installed fakevar, skip to step #8. However, doing the below commands won't hurt either way.

    5) Now type: rm -rf /var/mobile/fakevar

    6) Type: rm -rf /var/MobileSoftwareUpdate/mnt1/fakevar (if this says file not found, don't worry about it)

    7) Type: ls /var/mobile (make sure you don't see fakevar listed there). Exit Newterm.

    8) Go to Cydia and add repo https://cydia.ichitaso.com

    9) Go to Cydia and add repo https://level3tjg.me/repo

    10) For unc0ver jailbreaks only: Make sure you're running unc0ver 6.1.0 or above. Then search Cydia for libkrw (version 1.1.0 or higher), and install it.

    11) For Taurine jailbreaks only: Search for libKernRW, and install it.

    12) Search for and install "vnodebypass CC Module", and install it.

    13) Search for vnodebypass version (0.2.9 at the time of this post) and install it. Make sure you've installing version 0.2.9 or higher.

    14) Go to the new vnodebypass app installed on your home screen. Press Enable to enable it. Most jailbreak-detecting apps will now run and not crash.

    15) When done with those apps, go back to vnodebypass and click Disable. If phone is acting funny after this, reboot and rejailbreak.

    16) Make sure you DISABLE Liberty Lite or other jailbreak bypass applications -- at least for the ones which you couldn't get working before -- or this method won't work!

    That's it!

  2. #2
    Owner Dan Druff's Avatar
    Reputation
    8694
    Join Date
    Mar 2012
    Posts
    50,005
    Blog Entries
    2
    Load Metric
    29232415
    Oh, and if you have Sileo/Zebra, these will also cause vnodebypass to fail sometimes.

    You can fix this by adding them to the hiding list.

    The hiding list is located at /usr/share/vnodebypass/hidePathList.plist

    Then add these paths to the list:

    /Applications/Sileo.app
    /Applications/Zebra.app



    If you don't have Sileo or Zebra, then you can ignore this post.

  3. #3
    Owner Dan Druff's Avatar
    Reputation
    8694
    Join Date
    Mar 2012
    Posts
    50,005
    Blog Entries
    2
    Load Metric
    29232415
    NOTE:

    Certain iOS require Cydia package libkrw installed. So make sure you install that too, especially if vnodebypass gets "Failed" when you try it.

  4. #4
    Owner Dan Druff's Avatar
    Reputation
    8694
    Join Date
    Mar 2012
    Posts
    50,005
    Blog Entries
    2
    Load Metric
    29232415
    BUMP

    The October 2021 version of vnodebypass became partially obsolete, and didn't work with many apps attempting to detect jailbreak. As a result, there were several apps which simply could not be used with jailbreak, including the infamous Jack in the Box app, which is notoriously good at preventing jailbroken phones from accessing it.

    If your jailbreak is being detected, and your apps won't start, I have good news for you:

    vnodebypass just released a new version last week!

    Upgrading is pretty easy. Here are the instructions:

    1) Make sure you have repos of http://cydia.ichitaso.com and https://level3tjg.me/repo added to Cydia or whatever Cydia substitute you're using

    2) Go install "vnodebypass CC module" on your device. This is required for the new vnodebypass to work.

    3a) For unc0ver jailbreaks, make sure you have libkrw 1.1.0 or higher installed. If not, install/upgrade to the latest.

    3b) For unc0ver jailbreaks, make sure you are using unc0ver 6.1.0 or higher (the latest is much past that, just make sure you're not below 6.1.0)

    4) For Taurine jailbreaks, make sure you have libKernRW installed.

    5) For checkra1n or oddseyra1in jailbreaks, you can ignore #3 and #4. Taurine can ignore #3 above, unc0ver can ignore #4 above.

    6) Install vnodebypass 0.2.9


    Enjoy!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 10-01-2021, 10:10 AM
  2. Disable incognito mode detection in Chrome
    By Rally in forum The Hacker's Delight
    Replies: 1
    Last Post: 11-04-2019, 12:51 AM
  3. Replies: 0
    Last Post: 06-23-2016, 03:12 AM
  4. Replies: 8
    Last Post: 08-23-2013, 10:36 AM