Results 1 to 2 of 2

Thread: Fix for Realtek sound card stuttering, robotic sound, buzzing, freezing, delays

  1. #1
    Owner Dan Druff's Avatar
    Join Date
    Mar 2012
    Blog Entries

    Fix for Realtek sound card stuttering, robotic sound, buzzing, freezing, delays

    FIX #1:

    Realtek is the manufacturer for most of the sound cards shipped with PC laptops nowadays, especially HP and Dell.

    Unfortunately, the drivers have turned to shit, and the Indian support team at these companies just tells you to install the latest driver, and then tells you that the problem is all in your head.

    In reality, it's the bad Realtek driver causing this, and updating it won't help, as the new drivers are also shit. This problem started with Windows 10.

    Among the problems:

    - Sound lags (you hear it 1-3 seconds after expected)

    - Sound briefly freezes computer and gets distorted

    - Sound turns into a buzz or briefly gets robotic/tinny

    - Sound stutters, as if it's being briefly paused and unpaused

    All of this is unnerving, especially when playing games, watching YouTube, watching Netflix, etc.

    Fortunately there is a simple fix for all of this. Follow this easy-to-use guide, and you should have it taken care of within a few minutes.

    Note that you should only employ this situation if you are encountering one or more of the issues listed above. If your sound is working fine, don't bother with this.

    Instructions for fix:


    If this doesn't work, see the next post.

  2. #2
    Owner Dan Druff's Avatar
    Join Date
    Mar 2012
    Blog Entries
    FIX #2:

    Some of these problems are due to a Windows 10 feature called "Dynamic Tick".

    Dynamic Ticks are a feature that lets Windows stop the system timer when nothing is happening in order to conserve power. That might sound great, but this can backfire when not operating properly, causing all kinds of freezups and stutters, especially when gaming.

    You can disable these Dynamic Ticks without harming your system performance at all, by doing the following:

    1) In the search bar on the bottom left, type "cmd" (without the quotes), and then click on "Run as Administrator" on the right of the little window which pops up.

    2) At the command prompt, type: BCDEDIT /SET DISABLEDYNAMICTICK YES

    3) Next type: bcdedit /set useplatformclock true

    4) Restart computer

    That's it!

    If you want to re-enable Dynamic Ticks, do the same as above, except substitute "NO" for "YES" in Step #2, and substitute "false" for "true" in step #3.

    For the nerds, a longer explanation of why this works is below.

    Here is a technical discussion of the matter, if you'd like to understand what's happening:

    Here's another technical discussion of it:

    There's also a tool you can get to change the value of the system timer, which might be useful for gamers experiencing a stutter: .... However, try the above setting first before messing with this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PFA Radio... please fix the sound!!!
    By Daredevil in forum Flying Stupidity
    Replies: 2
    Last Post: 06-25-2014, 01:45 PM
  2. Druff, thanks for radio without sound effects
    By cleatus in forum Flying Stupidity
    Replies: 0
    Last Post: 11-09-2013, 05:17 PM
  3. Help with sound through headphones
    By Gordman in forum Flying Stupidity
    Replies: 11
    Last Post: 05-14-2013, 08:10 AM
  4. Just wanted to let everybody know I am home safe and sound
    By Bootsy Collins in forum Flying Stupidity
    Replies: 1
    Last Post: 08-31-2012, 04:03 PM
  5. Replies: 1
    Last Post: 06-21-2012, 03:11 AM